Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Configurar WildFly no Intellij

Estava usando o eclipse, mas tenho preferência pelo Intellij, configurar o tomcat é muito fácil no intellij, mas o WildFly é mais complicado. pois ele não carrega as classes já embutidas no servidor. Como faço as configurações para usar este projeto do curso JAVA EE no intellij?

4 respostas

Se o seu projeto estiver com maven Coloca as dependencias ( ou a dependencia do Java ee) como provided

Olá Francisco, obrigado pela resposta, mas já fiz este procedimento, meu projeto foi criado com o JBoss forge. se você tiver o intelliJ aí tenta testar.

Eis o meu pom.xml

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>br.com.casadocodigo</groupId>
  <artifactId>casadocodigo</artifactId>
  <version>1.0.0-SNAPSHOT</version>
  <packaging>war</packaging>
  <build>
    <finalName>casadocodigo</finalName>
  </build>
  <properties>
    <failOnMissingWebXml>false</failOnMissingWebXml>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
  </properties>
  <dependencies>
    <dependency>
      <groupId>org.jboss.spec.javax.faces</groupId>
      <artifactId>jboss-jsf-api_2.1_spec</artifactId>
      <scope>provided</scope>
    </dependency>
    <dependency>
      <groupId>javax.enterprise</groupId>
      <artifactId>cdi-api</artifactId>
      <scope>provided</scope>
    </dependency>
    <dependency>
      <groupId>javax.annotation</groupId>
      <artifactId>jsr250-api</artifactId>
      <scope>provided</scope>
    </dependency>
  </dependencies>
  <dependencyManagement>
    <dependencies>
      <dependency>
        <groupId>org.jboss.spec</groupId>
        <artifactId>jboss-javaee-6.0</artifactId>
        <version>3.0.3.Final</version>
        <type>pom</type>
        <scope>import</scope>
      </dependency>
      <dependency>
        <groupId>javax.annotation</groupId>
        <artifactId>jsr250-api</artifactId>
        <version>1.0</version>
        <scope>provided</scope>
      </dependency>
    </dependencies>
  </dependencyManagement>
</project>

oi Thiago, tudo bem?

como você fez pra importar e rodar o projeto no wildfly pelo intellij? E ao executar, você recebeu um erro?

Se puder passar mais detalhes sobre o que está acontecendo de errado, posso ir te guiando pra encontrarmos o problema juntos.

Eu já usei Intellij com WildFly em um projeto e nao tive muito trabalho, foi bem parecido com o setup do tomcat. Deve ser algum detalhe pequeno.

Thiago abre o Module Settings ( F4 sobre o projeto) Libraries -> adiciona as libs do seu wildfly.

Problema disso é que você vai ter que adicionar as libs uma a uma. Uma outra forma é você juntar todas essas libs em um diretório e adicionar-lo. ( As libs não pode estar em sub diretorios)

ve se ajuda.