Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Erro dependency all-themes

Olá, ocorreu o seguinte erro: Erro: Missing artifact org.primefaces.themes:all-themes:jar:1.0.10

Não só no meu projeto mas no download da própria aula também, acredito que seja alguma configuração do meu eclipse mas não identifiquei qual.

Obrigado

8 respostas

Oi Elison, tudo bem ?

Consegue postar para gente o seu pom.xml para gente dar uma olhadinha ?

Claro, segue o foto do erro e o código: http://prntscr.com/i7q44h

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <groupId>br.com.caelum</groupId>
    <artifactId>livraria-maven</artifactId>
    <version>0.0.1-SNAPSHOT</version>
    <packaging>war</packaging>
    <name>Livraria Alura</name>

    <dependencies>

        <dependency>
            <groupId>org.jboss.weld.servlet</groupId>
            <artifactId>weld-servlet</artifactId>
            <version>2.4.6.Final</version>
        </dependency>

        <dependency>
            <groupId>javax.validation</groupId>
            <artifactId>validation-api</artifactId>
            <version>1.0.0.GA</version>
        </dependency>

        <dependency>
            <groupId>org.primefaces</groupId>
            <artifactId>primefaces</artifactId>
            <version>5.3</version>
        </dependency>

        <dependency>
            <groupId>mysql</groupId>
            <artifactId>mysql-connector-java</artifactId>
            <version>5.1.22</version>
        </dependency>

        <dependency>
            <groupId>org.hibernate</groupId>
            <artifactId>hibernate-entitymanager</artifactId>
            <version>5.2.12.Final</version>
        </dependency>

        <dependency>
            <groupId>com.sun.faces</groupId>
            <artifactId>jsf-api</artifactId>
            <version>2.2.13</version>
        </dependency>

        <dependency>
            <groupId>com.sun.faces</groupId>
            <artifactId>jsf-impl</artifactId>
            <version>2.2.13</version>
        </dependency>

        <dependency>
            <groupId>org.primefaces.themes</groupId>
            <artifactId>all-themes</artifactId>
            <version>1.0.10</version>
        </dependency>

    </dependencies>

     <repositories>
        <repository>
            <id>prime-repo</id>
            <name>PrimeFaces Maven Repository</name>
            <url>http://repository.primefaces.org</url>
            <layout>default</layout>
        </repository>
    </repositories> 

    <properties>
        <maven.compiler.source>1.8</maven.compiler.source>
        <maven.compiler.target>1.8</maven.compiler.target>
    </properties>

</project>

Aparentemente está certo, mas de qualquer forma, consegue confirmar para mim se você fez todas as etapas da documentação ?

https://www.primefaces.org/themes/

Na parte da comunidade no fim da página ele mostra o que precisa ser feito.

Sim fiz várias vezes pois achava que tinha algo errado nessa parte. Mas até quando avanço a aula e abaixo a versão com spring da o mesmo erro, no mesmo lugar. Então acredito ser alguma configuração com meu eclipse, mas não estou conseguindo identificar o que pode ser

Parece que está certo sim, entrei na documentação, no repositorio do maven para checar e tudo está correto.

Vale a pena você fazer um teste em outra máquina.

Talvez, reinstalar o eclipse e ver o que rola

Eu baixei o eclipse (mars) junto com o professor, vou tentar baixar novamente com outra versão e ver se funciona. Obrigado

Olá Matheus, Uma notícia boa e outra ruim. Descobri que se eu deletar a minha pasta .m2 e pedir para o Eclipse baixar as dependências novamente ai sim funciona. O problema é que se eu fizer isso a falta dos repositórios anteriores ocasiona erro em outras aplicações.

Então preciso descobrir uma forma de adicionar essas dependências sem que haja conflito. Obrigado

solução

Matheus descobri, o que acontece Eu estava usando a última versão entitymanager disponível:

org.hibernate hibernate-entitymanager 5.2.12.Final

Porém é ele quem geral esse conflito com a biblioteca dos outros jars. Então para resolver utilizei uma versão mais antiga que veio a ter maior compatibilidade com os jars do projeto. Segue o que usei:

org.hibernate hibernate-entitymanager 5.1.0.Final