Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Vulnerabilities

Ao instalar alguns plugins o NPM alerta que encontrou algumas vulnerabilidades. Devo me preocupar com elas?

Até o módulo 3 foram 3. Segue a descrição delas:

=== npm audit security report ===

                             Manual Review
         Some vulnerabilities require your attention to resolve

      Visit https://go.npm.me/audit-guide for additional guidance

Low Prototype Pollution

Package lodash

Patched in >=4.17.5

Dependency of grunt-usemin [dev]

Path grunt-usemin > lodash

More info https://npmjs.com/advisories/577

High Prototype Pollution

Package lodash

Patched in >=4.17.11

Dependency of grunt-usemin [dev]

Path grunt-usemin > lodash

More info https://npmjs.com/advisories/782

High Prototype Pollution

Package lodash

Patched in >=4.17.12

Dependency of grunt-usemin [dev]

Path grunt-usemin > lodash

More info https://npmjs.com/advisories/1065

found 3 vulnerabilities (1 low, 2 high) in 3638 scanned packages 3 vulnerabilities require manual review. See the full report for details.

1 resposta
solução

Bom dia, Paulo! Como vai?

A título de desenvolvimento experimental para estudo, vc não precisa se preocupar com as vulnerabilidades. Contudo, passando para um projeto real, o ideal é que vc verifique na documentação dessas bibliotecas as implicações dessas vulnerabilidades e veja qual tipo de impacto elas trarão ao seu projeto.

Pegou a ideia? Qualquer coisa é só falar!

Grande abraço e bons estudos, meu aluno!