Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Erro execução jshint

Está dando o seguinte erro quando eu executo o comando $ grunt jshint

C:\Users\Tatiane\Desktop\Grunt>grunt jshint Warning: Task "jshint" not found. Use --force to continue.

Aborted due to warnings.

O que pode ser? Como posso resolver?

Em meu arquivo Gruntfile:

jshint: {
      js: {
        src: ['public/js/**/*.js']
      }
    }
8 respostas

Você precisa compartilhar o código do script inteiro. Apenas com esse não dá para saber o problema.

No aguardo.

module.exports = function(grunt) {

  grunt.initConfig({

    copy: {
      public: {
        expand: true,
        cwd: 'public',
        src: '**',
        dest: 'dist'
      }
    },

    clean: {
      dist: {
        src: 'dist'
      }
    },

    useminPrepare: {
      html: 'dist/**/*.html'
    },

    usemin: {
      html: 'dist/**/*.html'
    },

    imagemin: {
      public: {
        expand: true,
        cwd: 'dist/img',
        src: '**/*.{png,jpg,gif}',
        dest: 'dist/img'
      }
    },

    rev: {
      options: {
        encoding: 'utf8',
        algorithm: 'md5',
        length: 8
      },
      imagens: {
        src: ['dist/img/**/*.{png,jpg,gif}']
      },
      minificados: {
        src: ['dist/js/**/*.min.js', 'dist/css/**/*.min.css']
      }
    },

    coffee: {
      compilar: {
        expand: true,
        cwd: 'public/coffee',
        src: ['**/*.coffee'],
        dest: 'public/js',
        ext: '.js'
      }
    },

    less: {
      compilar: {
        expand: true,
        cwd: 'public/less',
        src:['**/*.less'],
        dest: 'public/css',
        ext: '.css'
      }
    },

    watch: {
      coffee: {
        options: {
          event: ['added', 'changed']
        },
        files: 'public/coffee/**/*.coffee',
        tasks: 'coffee:compilar'
      },
      less: {
        options: {
          event: ['added', 'changed']
        },
        files: 'public/less/**/*.less',
        tasks: 'less:compilar'
      }
    },

    jshint: {
      js: {
        src: ['public/js/**/*.js']
      }
    }

  });

  //registrando task para minificação
  grunt.registerTask('dist', ['clean', 'copy']);

  grunt.registerTask('minifica', ['useminPrepare', 'concat', 'uglify', 'cssmin', 'rev', 'usemin', 'imagemin']);

  //registrando tasks
  grunt.registerTask('default', ['dist', 'minifica']);

  //carregando tasks
  grunt.loadNpmTasks('grunt-contrib-copy');
  grunt.loadNpmTasks('grunt-contrib-clean');
  grunt.loadNpmTasks('grunt-contrib-concat');
  grunt.loadNpmTasks('grunt-contrib-uglify');
  grunt.loadNpmTasks('grunt-contrib-cssmin');
  grunt.loadNpmTasks('grunt-usemin');
  grunt.loadNpmTasks('grunt-contrib-imagemin');
  grunt.loadNpmTasks('grunt-rev');
  grunt.loadNpmTasks('grunt-contrib-less');
  grunt.loadNpmTasks('grunt-contrib-coffee');
  grunt.loadNpmTasks('grunt-contrib-watch');

}
solução

Faltou carregar o módulo do jshint:

grunt.loadNpmTasks('grunt-contrib-jshint');

Flavio Henrique de Souza Almeida, Olhei o video "6 - Realtime linting" novamente e em momento algum é citado o carregamento do módulo. Sugiro refazerem o vídeo da forma correta então se o problema é este.

Tatiane, estamos falando do mesmo vídeo ? Por volta de1:30 do video, em destaque, peço para carregar o módulo.

Então olha de novo o video, o que tu ensina no video é isso:

jshint: { js: { src: ['public/js/*/.js'] } }

e não o que tu citou como resolução do problema aqui no forum.

Você viu em 1:30? Viu o destaque que aparece encima do terminal ? Esta lá.

Aparece escrito "nao esqueça de...".

Se achar que o aviso no video não é suficiente ou prejudicou em algo você pode sugerir uma melhoria na propria plataforma. Vá até cap e clique sugerir melhoria. Isso vai direto para a equipe.