Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Erro no projeto android

Ola estou com um problema com projeto, quando eu Run no app para verificar no emulador do app, da um mensagem de erro.

Lembrando que eu ja liguem servidor.

ERROR: Failed to resolve: org.junit.jupiter:junit-jupiter-api:
Affected Modules: app

app code:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 28
    defaultConfig {
        applicationId "br.com.alura.leilao.guilherme"
        minSdkVersion 15
        targetSdkVersion 28
        versionCode 1
        versionName "2.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }

}

dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    implementation 'com.android.support:appcompat-v7:28.0.0'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    testImplementation 'org.junit.jupiter:junit-jupiter-api'
    testImplementation 'org.hamcrest:hamcrest-all:1.3'
    testImplementation 'org.mockito:mockito-core:2.15.0'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
    implementation 'com.android.support:recyclerview-v7:28.0.0'
    implementation 'com.android.support:design:28.0.0'
    implementation 'com.squareup.retrofit2:retrofit:2.4.0'
    implementation 'com.squareup.okhttp3:logging-interceptor:3.10.0'
    implementation 'com.squareup.retrofit2:converter-gson:2.4.0'
    implementation 'org.junit.jupiter:junit-jupiter-api'
    implementation 'org.testng:testng:6.9.6'
}
7 respostas

Oi Guilherme, tudo bem? Essa junit-jupiter-api precisa da versão para que o Gradle consiga buscá-la nos repositórios configurados, assim como as outras dependências mantém suas versões declaradas. Caso indique a versão e não resolva, precisa verificar o repositório configurado, pois geralmente é configurado o da Google ou da Jcenter

Aqui o codigo do build gradle Leilao:

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {

    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2.1'


        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

e o gradle-wrapper.properties:

#Mon Nov 19 15:33:39 AMST 2018
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.zip

Oi Guilherme, mesmo indicando a versão desejada ainda apresenta problema? Os seus arquivos de build para o projeto e para o gradle wrapper estão Ok. Precisa apenas ficar atento na declaração da API org.junit.jupiter:junit-jupiter-api, ela precisa ter a versão de maneira explícita para funcionar, como por exemplo:

implementation org.junit.jupiter:junit-jupiter-api:5.3.2

Nessa declaração é indicada a versão 5.3.2.

[]s

Ja coloquei versao 5.3.2 e outra também deu na mesmo erro persiste

Bem estranho, eu testei aqui e deu certo.

Vamos tentar algumas alternativas, a primeira vai ser na limpeza do projeto e rebuild. Para isso utilize o atalho Ctrl + Shift+ A ele vai abrir a funcionalidade chamada de find action que permite buscar qualquer função do Android Studio, então digite clean project e execute. Novamente com o mesmo atalho, busque por rebuild project.

Se após finalizar não funcionar, com o mesmo atalho tente Sync project with gradle files. Então, se não funcionar também, com o mesmo atalho tente a opção Invalidate Cache / Restart > Invalidate Restart. Aguarde o Android Studio finalizar o procedimento e veja se funciona.

Se, mesmo assim, apresentar problemas, por favor, compartilhe o projeto comigo via GitHub para eu dar uma olhada, pode ser um falha na configuração.

[]s

solução

Ola ja resolvi o problema, era que tinha 2:

testImplementation 'org.junit.jupiter:junit-jupiter-api:5.3.2'
implementation 'org.junit.jupiter:junit-jupiter-api'

Eu tirei "implementation 'org.junit.jupiter:junit-jupiter-api".

Oi Guilherme, boa!

Considerando que o problema está resolvido, pode marcar o tópico como solucionado?

[]s