Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Uncaught ReferenceError: require is not defined at renderer.js:1

Boa tarde pessoal.

Estou enfrentando dificuldades na Aula 2 do curso.

A janela "Sobre" está apresentando o erro abaixo: Uncaught ReferenceError: require is not defined at renderer.js:1

Coletei esta mensagem no painel do desenvolvedor.

Segue o código do arquivo:

const { ipcRenderer } = require('electron');
let linkSobre = document.querySelector('#link-sobre');

linkSobre.addEventListener('click', function() {
  ipcRenderer.send('abrir-janela-sobre');
});

Alguem sabe o que está acontecendo e como resolver ?

Obrigado!

5 respostas

Tentei reinstalar tudo seguindo o passo a passo do curso e não tive sucesso.

Node: v10.16.0 npm: 6.9.0 electron: 5.0.3

Obs: Criei os diretórios e arquivos exatamente como mostrado no curso até a aula 2.

package.json

{
  "name": "alura-timer",
  "version": "1.0.0",
  "description": "",
  "main": "main.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "start": "electron ."
  },
  "author": "",
  "license": "ISC",
  "dependencies": {},
  "devDependencies": {
    "electron": "^5.0.3"
  }
}

Fala ai Victor, tudo bem? Esse problema parece ser em relação a sua versão do Electron.

A partir da versão 5.x.x eles mudaram o valor padrão do nodeIntegration de true para false, dessa maneira vai ocasionar esse pequeno problemas.

Para resolver, você pode tentar voltar o valor para true novamente, isso pode ser feito durante a criação de um BrowserWindow, algo assim:

const win = new BrowserWindow({
    webPreferences: {
        nodeIntegration: false
    }
})
win.show()

Espero ter ajudado.

Boa noite Matheus, obrigado pelo apoio.

Infelizmente não funcionou :(

Estou dando uma olhada em outros fóruns pra ver se encontro a solução.

Tentei instalar a mesma versão usada no curso e também não funcionou. Acho que pode estar relacionado a configuração do ambiente.

Estou usando PopOs, uma distro baseada no Ubuntu, pode ser que seja necessária alguma instalação adicional.

Assim que encontrar uma solução posto aqui.

Certo, tente fazer o downgrade da sua versão para a utilizada no curso.

Assim você terá menos problemas, quando acabar o curso pode tentar atualizá-lo.

Espero ter ajudado.

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software