Solucionado (ver solução)
Solucionado
(ver solução)
1
resposta

[Projeto] Minha solução

Boa tarde, consegui fazer o desafio sozinho pela primeira vez. Gostaria de saber se ele está 'correto', se alguém puder dar sugestões seria de grande ajuda.

OBS: Ainda não terminei estou tentando achar um jeito de verificar se o valor da quantidade escolhida é maior do que a quantidade disponivel

function comprar(){
    //recuperar os valores de quantidade,de selecionar, de quantidade disponivel.
    let tipoIngresso = document.getElementById('tipo-ingresso').value;

    let quantidade = document.getElementById('qtd').value;

    let quantidadePista = document.getElementById('qtd-pista').textContent;

    let quantidadeSuperior =  document.getElementById('qtd-superior').textContent;

    let quantidadeInferior =   document.getElementById('qtd-inferior').textContent;

    let numeroInteiro1 = parseInt(quantidadePista);
    let numeroInteiro2 = parseInt(quantidadeSuperior);
    let numeroInteiro3 = parseInt(quantidadeInferior) ;


    

    //verificar se o valor da quantidade escolhida é maior do que a quantidade disponivel 
 



    //subtrair a quantidade disponivel pelo a quantidade escolhida e retornar o valor para quantidade disponivel.
    if (quantidade >= 0  && tipoIngresso == 'pista'){
     let   resultado = numeroInteiro1 - quantidade;
    let modificandoPista = document.getElementById('qtd-pista');

    modificandoPista.textContent = `${resultado}`;
    }
    else if (quantidade >= 0  && tipoIngresso == 'superior'){
        resultado = numeroInteiro2 - quantidade;
        modificandoPista = document.getElementById('qtd-superior');

    modificandoPista.textContent = `${resultado}`;
    }
    else {  resultado = numeroInteiro3 - quantidade;
        modificandoPista = document.getElementById('qtd-inferior');

        modificandoPista.textContent = `${resultado}`;

    }

    



}
1 resposta
solução!

Uma dica seria evitar dar nomes tão genéricos para suas variáveis, como numeroInteiro1, numeroInteiro2 e numeroInteiro3. Para fins de prática, isso até funciona, mas seria interessante usar nomes mais descritivos para ajudar outras pessoas a entender melhor o que está sendo manipulado no seu código.

Por exemplo, você poderia nomear as variáveis como varPista, varSuperior e varInteiro. O "var" seria uma abreviação de "variável", indicando que ela está sendo tratada para uso nas funções, enquanto o restante do nome mantém o significado original das variáveis, o que facilita a compreensão, principalmente se elas representarem algo específico no front-end.

Para calcular se a quantidade comprada é maior que a quantidade disponível, você poderia somar as quantidades disponíveis em uma única variável, como varDisponivel. Depois, com um if, você poderia verificar: se varDisponivel for menor que a quantidade comprada, então a quantidade comprada é maior que a disponível. Caso contrário, um else informaria que ainda há vagas disponíveis. Você também poderia adicionar uma terceira validação para verificar se varDisponivel é igual à quantidade, indicando que a quantidade de vagas foi totalmente esgotada mas todo mundo conseguiu sentar rs.

P.S.: Se quiser limitar a comparação aos setores, primeiro crie três variáveis para armazenar a quantidade vendida de cada setor com base no tipo do ingresso e depois faça o mesmo comparativo acima para cada uma delas. Assim, você terá uma validação específica para aquele setor. Minha solução seria para a quantidade geral da sala.

Mas você está no caminho certo! Muito obrigado por compartilhar sua conquista de ter feito o desafio sozinho. Ficamos felizes com seu progresso. Continue assim!