Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Problemas para subir o alurapic

Estou fazendo o curso de Angular , baixei o projeto Alurapic, instalei as versões: node 6.15.1 @angular-devkit/architect 0.6.8 @angular-devkit/build-angular 0.6.8 @angular-devkit/build-optimizer 0.6.8 @angular-devkit/core 0.6.8 @angular-devkit/schematics 0.6.8 @angular/cli 6.0.8 @ngtools/webpack 6.0.8 @schematics/angular 0.6.8 @schematics/update 0.6.8 rxjs 6.4.0 typescript 2.7.2 webpack 4.8.3

Ao subir a aplicação gera o seguinte erro:

PS C:\angular\alurapic> npm start

> alurapic@0.0.0 start C:\angular\alurapic
> ng serve

** Angular Live Development Server is listening on localhost:4200, open your browser on http://localhost:4200/ **

Date: 2019-04-07T15:28:13.908Z
Hash: 3130830d7b66e7df68d5
Time: 6883ms
chunk {main} main.js, main.js.map (main) 1.9 kB [initial] [rendered]
chunk {polyfills} polyfills.js, polyfills.js.map (polyfills) 665 bytes [initial] [rendered]
chunk {runtime} runtime.js, runtime.js.map (runtime) 5.22 kB [entry] [rendered]
chunk {styles} styles.js, styles.js.map (styles) 15.6 kB [initial] [rendered]
chunk {vendor} vendor.js, vendor.js.map (vendor) 335 kB [initial] [rendered]

ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.
15 respostas

Oi Max tudo bem?

Poderia, por gentileza, colocar a sua pasta do projeto no github. Assim poderemos analisar da melhor forma o que está acontecendo.

Bom dia André segue o link no github https://github.com/maxrporto/alurapic.git

Bom dia Max,

Tive o mesmo erro que você no seu projeto e consegui resolver. Resolva assim:

Apague a pasta node_modules.

Instale tudo novamente com

npm install --save

E depois atualize o Angular com

ng update @angular/cli @angular/core

Espero ter ajudado!!!

Boa noite, faz dois dias que tento baixar novamente a aplicação da alurapic, sem sucesso

segue o erro : npm ERR! asyncWrite is not a function Versão do angular

C:>ng --version

 _                      _                 ____ _     ___
/ \   _ __   __ _ _   _| | __ _ _ __     / ___| |   |_ _|

/ △ \ | '_ \ / | | | | |/ _ | '| | | | | | | / _ | | | | (| | || | | (| | | | || | | | // \_| ||_, |_,||__,|| ___|__|| |___/

Angular CLI: 6.0.7 Node: 8.15.1 OS: win32 x64 Angular: ...

Package Version

@angular-devkit/architect 0.6.7 @angular-devkit/core 0.6.7 @angular-devkit/schematics 0.6.7 @schematics/angular 0.6.7 @schematics/update 0.6.7 rxjs 6.4.0 typescript 2.7.2

Esse erro é diferente do outro certo?

O código que está naquele repositório do github é o mesmo que você está tendo problemas ou você mudou ele? Digo isso porque quero simular o cenário para ter o mesmo erro que você então tentar consertar.

é outro erro ... desinstalei o node vou tentar novamente

Olha só ... vou desistir do curso angular da alura pois não consigo baixar a estrutura do angular/cli, gera o seguinte erro

npm ERR! code EINTEGRITY
npm ERR! sha512-FPIb2j3zfoBwb6vo/u0gQeu70h8InGlSisBr3xMACs/35/pwB6kbQR+JQiUr0D7k6QApg7AuMkvq8aFNelg0aw== integrity checksum failed when using sha512: wanted sha512-FPIb2j3zfoBwb6vo/u0gQeu70h8InGlSisBr3xMACs/35/pwB6kbQR+JQiUr0D7k6QApg7AuMkvq8aFNelg0aw== but got sha512-02Z/SBqMpGMjlhDe8nVVjELX4jLPN1OdCMsDpcVICgaObvJTvgNEd9dTHYUAWvFNJCky4BpTYGxBgjmRwScW/A==. (330470 bytes)

Max, nao desista. Esse comecinho do npm e instalacoes sempre apresentam uma barreira.

Voce pode tentar o seguinte pra mim?

npm cache verify

npm cache clean --force

E depois o comando que executou exatamente antes do erro?

Max, realmente esse segundo problema não é do Angular em si, mas do Node. Você já comentou ter desinstalado e tentado novamente.

Antes estava usando a versão 8, mas que versão está usando agora? A 10?

Max, acabei de iniciar o curso e estava tendo o mesmo problema. Subiu o servidor assim. Deixa o seu package.json assim:

{
  "name": "alura-angular-p1",
  "version": "0.0.0",
  "scripts": {
    "ng": "ng",
    "start": "ng serve",
    "build": "ng build",
    "test": "ng test",
    "lint": "ng lint",
    "e2e": "ng e2e"
  },
  "private": true,
  "dependencies": {
    "@angular/animations": "^6.0.3",
    "@angular/common": "^6.0.3",
    "@angular/compiler": "^6.0.3",
    "@angular/core": "^6.0.3",
    "@angular/forms": "^6.0.3",
    "@angular/http": "^6.0.3",
    "@angular/platform-browser": "^6.0.3",
    "@angular/platform-browser-dynamic": "^6.0.3",
    "@angular/router": "^6.0.3",
    "core-js": "^2.5.4",
    "rxjs": "6.0.0",
    "zone.js": "^0.8.26"
  },
  "devDependencies": {
    "@angular/compiler-cli": "^6.0.3",
    "@angular-devkit/build-angular": "~0.6.6",
    "typescript": "~2.7.2",
    "@angular/cli": "~6.0.7",
    "@angular/language-service": "^6.0.3",
    "@types/jasmine": "~2.8.6",
    "@types/jasminewd2": "~2.0.3",
    "@types/node": "~8.9.4",
    "codelyzer": "~4.2.1",
    "jasmine-core": "~2.99.1",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "~1.7.1",
    "karma-chrome-launcher": "~2.2.0",
    "karma-coverage-istanbul-reporter": "~2.0.0",
    "karma-jasmine": "~1.1.1",
    "karma-jasmine-html-reporter": "^0.2.2",
    "protractor": "~5.3.0",
    "ts-node": "~5.0.1",
    "tslint": "~5.9.1"
  }
}

Em complemento, para quem estiver com outras versões, tenta soh modificar o objeto 'dependencies' com "rxjs": "6.0.0", q foi basicamente a unica coisa q eu modifiquei,

daih, vc faz no projeto:

npm update

vai atualizar e daih, quando subi de novo com

ng serve --open 

funcionou.

Fiz o que vc mencionou sem sucesso, continua com o mesmo problema, desisti do curso de angular da Alura.

Max, desculpa, mas você não me respondeu. :(Que versão do Node você está usando?

Boa tarde , estou com a versão do node -v: v8.8.1 npm -v: 6.1.0 instalei como recomentado no curso o angular cli: npm install -g @angular/cli@6.0.7

fui dar um ng --version gera o seguinte informação

You are running version v8.8.1 of Node.js, which is not supported by Angular CLI v6.
The official Node.js version that is supported is 8.9 and greater.

Please visit https://nodejs.org/en/ to find instructions on how to update Node.js.

Galera vamos de novo, consegui instalar tudo corretamente, porém quando vou subir o projeto com o comando ng serve --open, gera o erro abaixo

** Angular Live Development Server is listening on localhost:4200, open your browser on http://localhost:4200/ **

Date: 2019-05-16T17:39:44.934Z
Hash: a5961614e65b42030c97
Time: 2724ms
chunk {main} main.js, main.js.map (main) 343 kB [entry] [rendered]
chunk {polyfills} polyfills.js, polyfills.js.map (polyfills) 342 kB [entry] [rendered]
chunk {runtime} runtime.js, runtime.js.map (runtime) 5.22 kB [entry] [rendered]
chunk {styles} styles.js, styles.js.map (styles) 357 kB [entry] [rendered]
chunk {vendor} vendor.js, vendor.js.map (vendor) 9.17 kB [initial] [rendered]

ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.
node_modules/rxjs/internal/types.d.ts(82,52): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(82,88): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(82,92): error TS1109: Expression expected.
solução

Max, boa tarde!

Tente rodar os comandos abaixo no seu console:

npm install rxjs@6.0.0 --save
ng serve --open

Espero ter ajudado e bons estudos!