Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Problemas na execução do puppet apply

Alguém poderia me ajudar com este problema: Não estou conseguindo executar o comando sudo puppet apply /vagrant/manifests/web.pp da aula 1 atividade 11

Esta dando este erro:

Error: Could not find command '/usr/bin/apt-get' Error: /Stage[main]/Main/Exec[apt-update]/returns: change from notrun to 0 failed: Could not find command '/usr/bin/apt-get' Notice: /Stage[main]/Main/Package[openjdk-7-jre]: Dependency Exec[apt-update] has failures: true Warning: /Stage[main]/Main/Package[openjdk-7-jre]: Skipping because of failed dependencies Notice: /Stage[main]/Main/Package[tomcat7]: Dependency Exec[apt-update] has failures: true Warning: /Stage[main]/Main/Package[tomcat7]: Skipping because of failed dependencies Notice: Finished catalog run in 0.11 seconds

3 respostas
solução

Oi Juliano, tudo bem? Muito estranho esse erro, ele não tá achando o apt-get. A VM é Ubuntu mesmo? Que versão? Você poderia me disponibilizar o código do seu web.pp aqui pra gente ver o que pode ser?

Olá Wanderson, obrigado pela interação e por tentar me ajudar! Mas já resolvi esse problema. Acabei criando outra VM com o Ubuntu e funcionou. Estava utilizando o CentOs...

Sensacional Juliano! Obrigado por compartilhar com a gente aqui a sua solução. Bons estudos!