Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Problema na importação do projeto

Bom dia a todos!!

Recorro à ajuda de quem puder me ajudar, pois estou preparando o ambiente de desenvolvimento para seguir neste curso conforme orientação, já instalados eclipse(neon), tomcat8 e mysql, mas ao importar o projeto tenho o erro conforme abaixo gerado por alguma inconsistência no arquivo pom.xml nas linhas 1 e 103 do build.

Observação: já importei a versão do projeto que o Nico Steppat disponibilizou em outra ocasião semelhante em 05/07/16 para o César Augusto neste fórum, mas não tive sucesso.

Agradeço antecipadamente qualquer apoio relacionado ao meu problema.

Atte. Vicente

Erro

Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6
Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6

Linha 1 do arquivo pom.xml

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">

Linha 103 do arquivo pom.xml Observação: a linha 103 do build abaixo refere-se à tag

<build>
        <finalName>projeto-jpa-2</finalName>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.3</version>
                <configuration>
                    <source>1.7</source>
                    <target>1.7</target>
                </configuration>
            </plugin>
        </plugins>
    </build>
5 respostas

Tive esse mesmo problema. Resolvi configurando uma versão mais antiga do maven(2.2.1).

Boa tarde, Álvaro! Ainda não estou nem conseguindo remover a versão existente, 3.3.9 para instalar a versão 2.2.1 conforme sua dica. Quando faço a remoção o eclipse pede para eu reiniciar, em seguida confiro a versão instalada e lá está ela(versão 3.3.9) instalada.

Fiz o seguinte:

Com o eclipse aberto -> Window -> preferences

Maven -> Installations

  • Click em Add;
  • Informe o diretório do novo Maven a ser utilizado;
  • Finish

Maven -> User Settings

  • Global Settings: Informe o arquivo settings.xml que esta no diretório conf dentro do novo Maven.
  • Informe o mesmo arquivo no User Settings.
  • Apply
  • OK
  • Janela de preferencias fechada no OK

Agora importe o projeto utilizando o Maven.

Funcionou aqui.

Continuo na batalha e agradecido pelo suporte. Infelizmente ainda não consegui. Segui vossa dica, com as versões 3.3.1 , 3.3.3, mas continua com a mesma mensagem de erro. Colocando versões mais antiga por exemplo, 2.2.1 tenho a mensagem "Target is not a supported Maven Home", sem suporte.

solução

Boa tarde! Consegui fazer a importação do projeto: Reconfigurando as variáveis de ambiente do maven conforme minhas pasta pasta local.

Variável de usuário:
    Nome da variável:  MAVEN_HOME
    Valor da variável:  C:\apache-maven-3.3.9

Acrescentei no path a variável criada conforme abaixo

Variável de usuário:
    Nome da variável:  PATH
    Valor da variável:    ;%MAVEN_HOME%\bin

Não sei se era preciso, mas removi a pasta "2.6" da pasta do maven C:\apache-maven-3.3.9\repo\org\apache\maven\plugins\maven-compiler-plugin

Em seguida importei o projeto novamente e não tive mais aquela mensagem indesejada de erro de importação.

Observação: agradeço o inestimável apoio do Álvaro Pereira Flôres.

Atte. Vicente