Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

PDO_SQLITE com erro

tentei instalar manualmente como sugeriram em outro tópico não funcionou, mas ele está habilitado na minha máquina tanto quando eu digito php -m mostra está dependencia como no php.ini, mas sempre que tento rodar um código que usa o pdo_sqlite dá esse erro. Versão do php é 7.4 e o SO é o ubuntu 18.04 lts HELP!

composer install PHP Warning: PHP Startup: Unable to load dynamic library 'pdo_sqlite' (tried: /usr/lib/php/20190902/pdo_sqlite (/usr/lib/php/20190902/pdo_sqlite: cannot open shared object file: No such file or directory), /usr/lib/php/20190902/pdo_sqlite.so (/usr/lib/php/20190902/pdo_sqlite.so: undefined symbol: php_pdo_unregister_driver)) in Unknown on line 0 Loading composer repositories with package information Installing dependencies (including require-dev) from lock file Nothing to install or update

1 resposta
solução

Resolvi, além de descomentar o a linha no php.ini, tive que atualizar o composer que estava reclamando toda hora porém, não estava reconhecendo a atualização então usai os parametros extras que indicaram no site do composer, e também tive que setar manualmente o interpretador para o php 7.4, o caminho dele no caso dentro do php storm por algum motivo ele não estava mais encontrando sozinho, enfim foi isso que resolveu

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software