Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se
1
resposta

OSPF não mostra as areas adjacentes

Estou travado na última configuração, quando digito "show ip router" não mostra minhas configurações de OSPF

Router 1

Router#show ip route 

Gateway of last resort is not set

     160.1.0.0/30 is subnetted, 1 subnets
C       160.1.1.0 is directly connected, Serial0/1/0
     170.1.0.0/30 is subnetted, 1 subnets
C       170.1.1.0 is directly connected, FastEthernet0/1
     180.1.0.0/30 is subnetted, 1 subnets
C       180.1.1.0 is directly connected, FastEthernet0/0
Router# show run
Building configuration...

Current configuration : 752 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 180.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 170.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1/0
 ip address 160.1.1.1 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 170.1.1.0 0.0.0.255 area 0
 network 180.1.1.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
Router#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
190.1.1.1         1   EXSTART/DR      00:00:32    180.1.1.1       FastEthernet0/0

Router 2

Router#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     180.1.0.0/30 is subnetted, 1 subnets
C       180.1.1.0 is directly connected, FastEthernet0/0
     190.1.0.0/30 is subnetted, 1 subnets
C       190.1.1.0 is directly connected, FastEthernet0/1
Router#show run
Building configuration...

Current configuration : 762 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 180.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 190.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 180.1.1.0 0.0.0.255 area 0
 network 190.1.1.0 0.0.0.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
Router#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
180.1.1.1         1   EXSTART/DR      00:00:36    180.1.1.1       FastEthernet0/0
1 resposta

Olá André,

Você configurou o IP 180.1.1.1 nas interfaces FastEthernet0/0 dos dois roteadores.

Tenta alterar o IP para 180.1.1.2 no Router2 que acredito resolver o problema.

Espero ter ajudado.

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software