1
resposta

Não roda xml

Mais um problema encontrado. gerenciador bem-vindo.html OiMundoServlet br.com.alura.gerenciador.servlet.OiMundo

OiMundoServlet ola

feito isso o Tomcat responde assim:

Insira aqui a descrição dessa imagem para ajudar na acessibilidade

1 resposta

Oi Carlos, como vai?

Me parece que você está com mais de uma versão do Tomcat, certo?

De qualquer forma, vamos retirar todos os servidores e subir novamente.

Vamos remover o Tomcat do seu projeto. Clique com o botão direito em cima do Tomcat e escolha a opção Delete. Veja:

Imagem do Tomcat instalado na IDE eclipse na aba server. O menu está selecionado em vermelho

Na barra de menu superior da IDE Eclipse selecione o opção Window; na sequência Preferences. Veja:

imagem da aba de menu superior do eclipse com as opções Window e Preferences

Na nova caixa que irá aparecer digite "server" na barra de pesquisa; Seleciona a opção Runtime Environments; Selecione todos os servidores disponíveis e aperte o botão Remove; clique em apply and close

Caixa de opções de preferences com o campo de busca preenchido com "server", a opção runtime environments, os servidores que estão na IDE eclipse e o campo remove está selecionado em vermelho

Acesse o seu "workspace" - a pasta onde fica localizado seus projetos, e siga esse caminho .metadata/.plugins/org.eclipse.core.runtime/.settings exclua esses dois arquivos:

  • org.eclipse.wst.server.core.prefs
  • org.eclipse.jst.server.tomcat.core.prefs

Reinicie a IDE Eclipse e suba novamente o Tomcat.

Qualquer dúvida estamos por aqui.

Abraços

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software