Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Modulo de temperatura/umidade funciona vezes sim vezes nao e display travado

Boa noite, configurei o componente de temperatura e umidade no esp8266 fiz o Serial.println() passando os logs igual no curso

dai ele mostra por um bom tempo o valor limite (que é o padrao aparentemente quando nao captura dado)

e as vezes ele mostra o valor correto


outra coisa, o display mostra temperatuda e um monte de pixel azul mais para o final da tela e nunca eh re-renderizado intercalando entre temperatura e umidade. Quando coloco um novo codigo para testar o display, tenho que desligar e ligar o es8266.

saberia me dizer o que esta acontecendo?

2 respostas

Pedro, ambos os pontos que destacou me parecem ser problemas de hardware. Eu sugiro que teste novos componentes de temperatura e display.

Eu estou com o mesmo problema em relação ao display (OLED 0.96″ I2C Azul Amarelo).

Como o Pedro disse, o display mostra "TEMPERATURA" em amarelo e um monte de pixel azul mais para o final da tela e trava, sequer alterando entre "TEMPERATURA" e "UMIDADE".

Ademais, quando coloco um novo código para testar o display, também tenho que desligar e ligar o esp8266.

O professor utiliza um display monocromático nas aulas. Como devo mudar a configuração do meu display no código para sanar o problema?

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software