Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Lite-server não instala corretamente

Ao tentar instalar o lite-server aparece o seguinte: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules\chokidar\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN alurabank@1.0.0 No description npm WARN alurabank@1.0.0 No repository field.

  • lite-server@2.3.0 updated 1 package in 11.609s

Não funciona no chrome. Ao rodar a aplicação aparece o seguinte Access to XMLHttpRequest at 'file:///C:/aaRauryGeral/Alura/TypeScript%20parte%202%20Mais%20t%C3%A9cnicas%20e%20boas%20pr%C3%A1ticas/10-alurabank/alurabank/app/js/app.js' from origin 'null' has been blocked by CORS policy: Cross origin requests are only supported for protocol schemes: http, data, chrome, chrome-extension, https.

1 resposta

Fala ai Raury, tudo bem? Pelo erro parece que a instalação esperava ser executada no Mac, mas, foi executada no Windows.

Tente apagar o package-lock e realizar o processo novamente.

Sobre o segundo erro, o erro de CORS é porque a API que o front está requisitando não configurou o CORS.

O CORS é uma maneira da gente garantir que apenas certas aplicações possam se comunicar com a nossa API.

Espero ter ajudado.

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software