Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

JBoss incompatível com Java 11

Boa noite ! Gostei do JBoss Forge, ele montou o esqueleto de um projeto web, é claro que vamos aprender configurações específicas para o projeto. Pena que ele é incompatível com o Java 11, já tinha removido o JDK8, tive que reativa-lo. Se alguém já sabe a solução, peço por gentileza que me responda.

2 respostas

Olá Marcelo!

Na seção "instalação" da documentação do JBoss Forge eles recomendam o Java 8:

https://forge.jboss.org/document/installation

Eu te recomendaria fortemente seguir as versões que são seguidas em aula.

O Java 8 ainda é muito utilizado no mercado. Você pode ter problemas de compatibilidade de bibliotecas caso queira usar outra versão. Isso pode ser uma barreira para seu andamento no curso.

Mas caso queira tentar eu encontrei um artigo que explica passo a passo como rodar o Java 11 com Jboss Forge:

https://vorozco.com/blog/2019/2019-04-29-Boostraping-Eclipse-Jboss-Tools.html

Espero que tenha ajudado.

Bons estudos! ^^

solução

Opa Guilherme, agradeço pelo seu feedback, deixei no meu pc as duas versões. Então eu usarei a versão 8 somente para gerar o projeto com oJBoss e no projeto usarei a versão mais recente.

Obrigado!!