Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

IONIC - Build android com onesignal

O push estava funcionando corretamente e o APP buildando normalmente mas agora acontece o seguinte erro:

  • Where: Build file 'C:\ionic\pushtest\platforms\android\app\build.gradle' line: 94

  • What went wrong: A problem occurred evaluating project ':app'.

    Could not resolve all files for configuration 'classpath'. Could not resolve gradle.plugin.com.onesignal:onesignal-gradle-plugin:[0.10.0, 0.99.9 9]. Required by:

       unspecified:unspecified:unspecified

    Could not resolve gradle.plugin.com.onesignal:onesignal-gradle-plugin:[0.10.0, 0.9 9.99]. Failed to list versions for gradle.plugin.com.onesignal:onesignal-gradle-plugin . Unable to load Maven meta-data from https://plugins.gradle.org/m2/gradle/plu gin/com/onesignal/onesignal-gradle-plugin/maven-metadata.xml. Could not HEAD 'https://plugins.gradle.org/m2/gradle/plugin/com/onesignal /onesignal-gradle-plugin/maven-metadata.xml'. sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certifica tion path to requested target

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

  • Get more help at https://help.gradle.org

BUILD FAILED in 7s

3 respostas

Boa tarde, Marcus! Como vai?

Vc conseguiu resolver esse problema? Eu fiz uma pesquisa sobre isso que aconteceu contigo achei esse link que diz que o problema é a versão do plugin do OneSignal.

Tbm encontrei esse outro link com uma solução um pouco diferente!

Vê se uma delas resolve o seu problema e me dá um retorno aqui para que eu possa tentar te ajudar caso o problema persista!

Grande abraço e bons estudos, meu aluno!

solução

Oi Gabriel, consegui resolver: reinstalei o plugin forçando a versão

Boa, Marcus! Só uma pergunta, a versão do plugin que vc forçou foi a 2.4.0? Com essa informação, outros alunos que possivelmente tiverem o mesmo problema saberão qual versão usar!

Sempre que vc tiver qualquer dúvida é só mandar aqui no fórum da Alura!

Grande abraço e bons estudos, meu aluno!