Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Formulário não renderiza 2

Já vi essa dúvida aqui duas vezes e nenhuma das duas vezes foi resolvida. Eu subo a aplicação, não da erro, inspeciono a página e está tudo lá certinho mas o formulário não renderiza. Um tópico ninguém respondeu nada sobre isso e no outro o cara conseguiu descobrir mas não postou a solução. Alguém sabe como soluciona isso?

4 respostas

Oi Gustavo, daí depende muito, não acontece nenhuma exception? Muitas vezes o servlet container que vc está usando não reconheceu sua aplicação ( ela não está setada dentro dele ). Tenta acessar só localhost:8080.

Qual IDE vc está usando?

Desculpas mas é que preciso de mais informações pra responder e entender o problema (:

Abraço!

Minha IDE: Eclipse - Version: Mars Release (4.5.0) Não houve nenhuma exception, nenhum erro na tela. Quando executo o index.html é exibida a mensagem corretamente, então minha aplicação está sendo executada. Porém, o form.xhtml não é exibido nada, só uma tela em branco. Quando inspeciono a página o código todo está lá, mas ainda em jsf, com as tags jsf, como etc. Não foi convertido para html. Desconfio que falta alguma configuração no jsf, mas não sei qual é.

O Forge não gerou o web.xml que fica no mesmo diretório que o faces-config gerado. Eu copiei de outro projeto e agora exibiu corretamente, pois precisa da informação

< url-pattern >*.xhtml< /url-pattern >

Puuts faz sentido, pior que essas coisas acaba demorando pra descobrir mesmo.

Valeu por colocar a solução Gustavo, abração!