Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Estou com um erro para utilizar um npm

mesmo de pois de importar o npm não consigo utiliza-lo em minha aplicação: import { ActionCard } from 'ps-react-bootstrap'; Erro:

./node_modules/ps-react-bootstrap/src/components/action-card/index.js SyntaxError: D:\Projetos\Alura\React\cdc-admin\node_modules\ps-react-bootstrap\src\components\action-card\index.js: Unexpected token (16:2)

14 | const ActionCard = ({ className, icon, children, ...props }) => { 15 | return (

16 | <div | ^ 17 | {...props} 18 | className={classnames(actionCardStyle.actionCard, className)} 19 | data-component-name="action-card

3 respostas

Fala aí Flávio, tudo bem? O que seria essa lib ps-react-bootstrap? Não seria apenas react-bootstrap?

Não conheço essa lib: ps-react-bootstrap, nem achei no npm para baixar.

Dá uma olhada na:

https://react-bootstrap.github.io/

O problema parece ser os arquivos dessa ps-react-bootrap, possuí um erro de sintaxe.

node_modules\ps-react-bootstrap\src\components\action-card\index.js

Mais especificamente, na linha 16.

Espero ter ajudado.

é um npm da empresa que presto serviços, eles até tem um repositório próprio pra acessa-lo, porem estou com esse erro, mas valeu, farei mais testes.

Abraço

Fala com eles então, o problema está no index.js do action-card.

Se a dúvida foi resolvido não esqueça de marcar o tópico como solucionado.

Abraços.