Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Estou com dúvida no curso de Desenvolvendo aplicações Web com Spring MVC 3, no exercício do capítulo Primeiros passos com Spring MVC.

Em alguns posts da internet ouvi dizer sobre a versão da Dynamic Web Module que não é compatível com Tomcat 7. Isto é verdade? Outra coisa com relação a 3.0 qual a diferença na prática.

2 respostas

Luis segue as versões compatíveis:

Servlet 3.0(Tomcat 7, Glassfish 3, Jboss 6, etc)

Servlet 2.5(Tomcat 6, Glassfish 2, Jboss 5, etc)

No servlet 3.0 entrou algumas funcionalidades. Sugiro que pesquise alguns exemplos na internet, também temos o curso de servlet 3 aqui no alura que é interessante.

segue um artigo bem antigo da caelum com um exemplo :

http://blog.caelum.com.br/java-ee6-comecando-com-as-servlets-3-0/

O link abaixo tem uma introdução detalhada sobre servlet 3.0, mas está em inglês:

https://jcp.org/en/jsr/detail?id=315

Mais nos exemplos estamos utilizando JSF com servlet 3 e Tomcat 7. Por isso estou achando estranho, como é isso?