Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se
1
resposta

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies

Olé pessoal!!! após executar o comando abaixo.

pip install apache-airflow==1.10.14 --constraint "https://raw.githubusercontent.com/apache/airflow/constraints-1.10.14/constraints-3.7.txt

eu acabo obtendo o erro abaixo

ERROR: Cannot install apache-airflow==1.10.14 because these package versions have conflicting dependencies.

The conflict is caused by:
    apache-airflow 1.10.14 depends on cattrs<1.1.0 and >=1.0; python_version <= "3.6"
    The user requested (constraint) cattrs==1.1.2

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies
(.env) policarpoj@cloudshell:datapipeline (sa-saopaulo-1)$ ^C
(.env) policarpoj@cloudshell:datapipeline (sa-saopaulo-1)$
1 resposta

Oii Policarpo, tudo bem contigo?

Peço desculpas novamente pela demora em dar um retorno.

Eu respondi sua dúvida no outro tópico que você havia postado com o mesmo erro. Para acessá-lo você pode clicar aqui.

Qualquer dúvida estou à disposição :)

Caso este post tenha lhe ajudado, por favor, marcar como solucionado ✓. Bons Estudos!

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software