Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se
Solucionado (ver solução)
Solucionado
(ver solução)
1
resposta

Erro no Composer Init [Composer\Exception\NoSslException]

Apareceu este erro ao tentar usar o comando Init, ele nem deixa eu informar (ou pular) a dependencia.

[Composer\Exception\NoSslException] The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl extension, you can disable this error, at your o wn risk, by setting the 'disable-tls' option to true.

Versão do composer: Composer version 2.1.3 2021-06-09 16:31:20 (windows)

Aqui as entradas do comando:

Package name (/) [otakejame/buscador-cursos-alura]: Description []: Buscador cursos Author [, n to skip]: n Minimum Stability []: Package Type (e.g. library, project, metapackage, composer-plugin) []: License []:

Define your dependencies.

1 resposta
solução!

Resolvido! Precisei habilitar a extensão Openssl no php.ini: removendo o comentário (;) da linha: extension=openssl

e como estou no windows, precisai remover o comentário (;) da linha: extension_dir = "ext"

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software