Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Erro no build

toda vez que tento fazer o build, ainda que seja em preview, dá um erro no projeto e fecha o unreal. "You do not have any debugging symbols required to display the callstack for this crash." instalei os símbolos do editor para correção de erros e o problema desapareceu, porém agora gera um outro problema quando vou fazer o build

Fatal error: [File:D:\Build\++UE4+Release-4.18+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 182] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0005 - 'REMOVED')

UE4Editor_Core!FDebug::AssertFailed() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:414]
UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:192]
UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:231]
UE4Editor_D3D11RHI!FD3D11Viewport::PresentChecked() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:289]
UE4Editor_D3D11RHI!FD3D11Viewport::Present() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:472]
UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIEndDrawingViewport() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:593]
UE4Editor_RHI!FRHICommandList::EndDrawingViewport() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:1607]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindow_RenderThread() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:883]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindows_Private()
1 resposta
solução

É algum erro na sua placa de vídeo pois D3D se refere a isso. Qual placa de vídeo você está usando? Ela atende as especificações para o projeto que está tentando compilar?