Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

erro na importação do projeto

Boa tarde,

Meu projeto começou a dar erro em todas as classes do nada no projeto android-sync.

no build.gradle ele esta dando erro também sempre na segunda linha da parte de dependencies. Tentei baixar o projeto disponibilizado de novo, e ele já vem com o mesmo problema.

nas classes, vários metodos estão em vermelho, EX: " Cannot resolve method findViewById"

segue a parte dependencies do gradle


dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'com.android.support:appcompat-v7:23.3.0'
    compile 'com.android.support:cardview-v7:23.3.0'
    compile 'com.android.support:support-v4:23.3.0'
    compile 'com.google.android.gms:play-services:8.4.0'
}

Não importa quem eu coloque na segunda linha, ele sempre estará em vermelho como se estivesse errado.

Poderia me ajudar? Obrigado

1 resposta
solução

Oi Victor, tudo bem?

Provavelmente é por causa da versão do SDK que está configurado, se estiver utilizando o Android Studio mais recente, ele deve ter orientado o uso de um SDK mais recente e talvez isso impactou na compilação. Me manda todo o código de configuração do seu build.gradle para eu verificar o possível problema.

Adiantando, se estiver utilizando, por exemplo, uma versão 27, vai ser necessário usar versões 27.x.y do com.android.support:z para poder compilar sem problemas.

[]s