Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se
1
resposta

Erro com as dependências

Olá, bom dia / tarde / noite

Estou recebendo erro logo que incluo os imports do componentes de navegação:

Insira aqui a descrição dessa imagem para ajudar na acessibilidade

Segue meu código para import:

Insira aqui a descrição dessa imagem para ajudar na acessibilidade

Rodei o comando npx pod-install e não houve erro: Insira aqui a descrição dessa imagem para ajudar na acessibilidade

Com o pod install, foi gerado o podfile a seguir (bem diferente de um podfile "normal"): Insira aqui a descrição dessa imagem para ajudar na acessibilidade

1 resposta

Olá Abner, tudo bem?

Isso pode estar acontecendo devido as versões do react-navigation instalada. Minha recomendação é que você desinstale todas os pacotes instalados e instale novamente com as versões usadas no curso. Então:

  1. Primeiro desinstale as bibliotecas e pacotes:

    npm rm @react-navigation/native
    npm rm react-native-reanimated react-native-gesture-handler react-native-screens react-native-safe-area-context @react-native-community/masked-view
  2. Instale novamente, mas com as versões setadas:

    npm install @react-navigation/native@5.7.1
    npm install react-native-reanimated@1.10.1 react-native-gesture-handler@1.7.0 react-native-screens@2.9.0 react-native-safe-area-context@3.1.1 @react-native-community/masked-view@0.1.10
    npm install @react-navigation/stack@5.7.1
    npx pod-install ios

Acredito que isso deva resolver o problema.

Caso este post tenha lhe ajudado, por favor, marcar como solucionado ✓. Bons Estudos!

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software