Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Erro ao executar o arquivo BAT

Ao executar o arquivo BAT, aparece a mensagem abaixo e não roda o jobPrincipal.

C:\treinamento\logs>executacarga.bat

C:\treinamento\logs>c:

C:\treinamento\logs>cd\

C:>cd c:\treinamento\designer-tools\data-integration

c:\treinamento\designer-tools\data-integration>kitchen.bat /rep:reposucos /job:jobPrincipal /dir: /level:Basic /log:"c:\treinamento\logs\jobLog.log" 1>"c:\treinamento\logs\consoleLog.log" Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0 mar 02, 2020 11:50:36 PM org.apache.karaf.main.Main$KarafLockCallback lockAquired INFORMAÇÕES: Lock acquired. Setting startlevel to 100 java.lang.NullPointerException at org.pentaho.di.core.plugins.PluginRegistry.getPluginId(PluginRegistry.java:671) at org.pentaho.di.core.plugins.PluginRegistry.getPlugin(PluginRegistry.java:697) at org.pentaho.di.core.plugins.PluginRegistry.loadClass(PluginRegistry.java:353) at org.pentaho.di.base.AbstractBaseCommandExecutor.establishRepositoryConnection(AbstractBaseCommandExecutor.java:162) at org.pentaho.di.kitchen.KitchenCommandExecutor.execute(KitchenCommandExecutor.java:113) at org.pentaho.di.kitchen.Kitchen.main(Kitchen.java:260) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.pentaho.commons.launcher.Launcher.main(Launcher.java:92)

c:\treinamento\designer-tools\data-integration>

Há alguma configuração a ser realizada para que o arquivo BAT execute normalmente?

1 resposta

E aí Fábio, tudo bom?

Peço imensas desculpas pela demora no retorno de sua resposta, vamos lá:

O erro retorna: Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m;

No Java 8, a opção do MaxPermSize foi retirada, então a JDK tá avisando que não vai usar esse parâmetro. Que eu saiba, isso não causa nenhuma problema.

Deve ter alguma coisa configurada errado em seu BAT. Abra o arquivo e verifique se as rotas estão certinhas, se puder compartilhar o consoleLog.log aqui, pra gente verificar se retornou algum erro diferente.

Não é necessário nenhuma configuração adicional para rodar o BAT.

Fico no seu aguardo :)