Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Erro 404

Boa noite!

Estou tentando abrir http://localhost:8080/casadocodigo, porém obtenho o erro 404 - Not Found. Se abro apenas http://localhost:8080 é ok. Por gentileza, podem me ajudar?

5 respostas

Olá,

Quando você executou o comando project-new qual foi o nome passado como parâmetro para o -named ?

Poderia enviar seu pom.xml para darmos uma olhada?

Abraço!

Bom dia!

O nome passado para o -named foi casadocodigo mesmo, conforme o exercício.

Segue conteúdo do pom.xml, Muito obrigada pela ajuda!

4.0.0 br.com.casadocodigo casadocodigo 1.0.0-SNAPSHOT war casadocodigo false 1.8 1.8 UTF-8 org.jboss.spec.javax.faces jboss-jsf-api_2.1_spec provided javax.enterprise cdi-api provided javax.annotation jsr250-api provided org.jboss.spec jboss-javaee-6.0 3.0.3.Final pom import javax.annotation jsr250-api 1.0 provided
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>br.com.casadocodigo</groupId>
  <artifactId>casadocodigo</artifactId>
  <version>1.0.0-SNAPSHOT</version>
  <packaging>war</packaging>
  <build>
    <finalName>casadocodigo</finalName>
  </build>
  <properties>
    <failOnMissingWebXml>false</failOnMissingWebXml>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
  </properties>
  <dependencies>
    <dependency>
      <groupId>org.jboss.spec.javax.faces</groupId>
      <artifactId>jboss-jsf-api_2.1_spec</artifactId>
      <scope>provided</scope>
    </dependency>
    <dependency>
      <groupId>javax.enterprise</groupId>
      <artifactId>cdi-api</artifactId>
      <scope>provided</scope>
    </dependency>
    <dependency>
      <groupId>javax.annotation</groupId>
      <artifactId>jsr250-api</artifactId>
      <scope>provided</scope>
    </dependency>
  </dependencies>
  <dependencyManagement>
    <dependencies>
      <dependency>
        <groupId>org.jboss.spec</groupId>
        <artifactId>jboss-javaee-6.0</artifactId>
        <version>3.0.3.Final</version>
        <type>pom</type>
        <scope>import</scope>
      </dependency>
      <dependency>
        <groupId>javax.annotation</groupId>
        <artifactId>jsr250-api</artifactId>
        <version>1.0</version>
        <scope>provided</scope>
      </dependency>
    </dependencies>
  </dependencyManagement>
</project>

Substituía a sua tag <build> pelo código abaixo:

<build>
    <finalName>casadocodigo</finalName>
    <plugins>
      <plugin>
        <artifactId>maven-war-plugin</artifactId>
        <version>2.6</version>
        <configuration>
          <failOnMissingWebXml>false</failOnMissingWebXml>
        </configuration>
      </plugin>
    </plugins>
  </build>

Olá!

Obrigada pela ajuda. Substituí, mas o problema permanece. Tem mais alguma sugestão?