2
respostas

[Dúvida] O ícone para setar variável já criada não está aparecendo para Layer.

Pessoal, não estou conseguindo fazer com que o ícone de setar uma variável apareça.

Já entrei na comunidade do figma e postei minha dúvida lá, mas conseguem me ajudar por aqui?

Só é possível definir uma propriedade, mas não consigo usar minhas variáveis. Insira aqui a descrição dessa imagem para ajudar na acessibilidade

2 respostas

Oi Esther, tudo bem?

Bom, analisando pelo print, eu imagino que você não esteja conseguindo pois esse não é o Main Component. Quando vc pretende fazer alguma adição em um componente, o Figma só permite fazer isso se for no componente principal, ou como eles chamam, Main Component, que é aquele primeiro que vc criou. Após isso, vc pode duplicar e utilizá-lo em vários lugares diferentes.

Clicando em qualquer componente "filho" (componente filho são os duplicados do componente principal), na barra da direita, onde tem os estilos, bordas e afins, irá aparecer uma seção com o nome do seu componente, e ao lado direito, o ícone de um losango. Clique nele, e você será direcionada para o seu Main Component. Ali você poderá adicionar as coisas que precisa!

Insira aqui a descrição dessa imagem para ajudar na acessibilidade

Oi!! Tudo bem sim e contigo?

Então, o problema era outro, hehe. Eu estava tentando colocar a layer na main mesmo, mas do jeito errado.

Eu deveria clicar com o botão direito em cima do ícone de olho ali na layer e assim eu conseguiria atribuir minha variável.

O pessoal da figma me respondeu com um artigo que eu li N vezes, mas não via que a resposta tava na minha cara, mas ok, agora foi kkkkk.

Obrigada Mateus!!

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software