Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Solucionado (ver solução)

Container não está rodando.

por mais que eu tente startar esse container, ele não funciona, o engraçado é que funciona para as outras images (Wordpress, Mysql), oque pode ser isso?

Mac:~ ramires$ docker ps -a
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS                     PORTS               NAMES
3977326a3225        centos              "/bin/bash"              13 minutes ago      Exited (0) 2 minutes ago                       servidor
920e5fdd02fc        wordpress           "/entrypoint.sh apach"   23 hours ago        Exited (0) 3 minutes ago                       blog-ramires
6279b6e84543        mysql               "docker-entrypoint.sh"   23 hours ago        Exited (0) 3 minutes ago                       database 
$ docker start servidor
servidor
$ docker exec -ti 3977326a3225 ps aux 
Error response from daemon: Container  3977326a3225c6418621c82d1dcce0618af9cce2b11beb667aaf0f2eeb98cf78 is not running
$ docker exec -ti servidor ps aux 
Error response from daemon: Container 3977326a3225c6418621c82d1dcce0618af9cce2b11beb667aaf0f2eeb98cf78 is not running
$
12 respostas

Nem executando como sudo ele inicia ?

Não, com outra imagem não oficial ele funciona, mas com a oficial ele não funciona de jeito nenhum, já restartei o docker assim como o próprio computador e nada, acredito que deve ser alguma variável de ambiente que deve ser configurara no container, mas não sei ao certo.

O interessante é que algo semelhante ocorreu com o vagrante, e so foi resolvido quando baixei outra imagem não oficial.

Como você fez a instalação do docker ?

eu instalei via interface grafica, será que é isso? seria melhor instalar via linha de comando?

brew install docker

mas o que explica outras imagens funcionarem? já testei com duas imagem diferentes e as duas funcionam. Será que é um problema da própria imagem? lembrando que estou usando a imagem centos

docker pull centos

imagens que funcionam:

nickistre/centos-lamp
circleci/ubuntu-server

e por ai vai.

Vou tentar rodar a imagem do centos aqui Ramires para confirmarmos se o problema esta na img.

Em breve lhe informo o resultado

Blz

Ramires a imagem esta OK, acabei de baixa-la e rodar um echo e o mesmo foi executado sem problemas.

solução

Bom dia Matheus! O problema foi resolvido com a instalação do docker toolbox, eu desinstalei o anterior.

Você fez a instalação via linha de comando e deu certo ?

Isso, e uma observação, o comando docker start só funciona se eu tiver rodado o container antes comdocker run -it ... bash pelo menos comigo só deu certo assim.

Mais aprendizados para a conta haha, bom saber desses detalhes.