Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

Configuração das versões 2.0 do CDI e 3.0.2 do Weld em Apache Tomcat 8.5

Pode ser útil para mais gente:

Configurei meu ambiente usando a versão 2.0 da API do CDI e a versão 3.0.2 do Weld, obtidos a partir de http://weld.cdi-spec.org/download/, adicionando a bibliotecas abaixo na pasta WebContent/WEB-INF/lib do projeto (e fiz um refresh do projeto eclipse):

cdi-api-2.0.jar
weld-servlet-shaded-3.0.2.Final.jar
weld-servlet-core-3.0.2.Final.jar

Estou utilizando o Apache Tomcat em sua versão 8.5.24, executando sob Java 8 update 152 (jre1.8.0_152).

Os arquivos XML de configuração utilizados foram os descritos no treinamento.

Todos os beans foram atualizados de @ManagedBean para @Named, as definições de escopo foram atualizadas também, todos os Beans passaram a implementar a interface Serializable e a aplicação passou por testes simples de uso com sucesso.

1 resposta

Bacana, Alex!

Que bom que funcionou com as bibliotecas atualizadas!

Muito obrigado!