3
respostas

coloquei UTF

E ai teve problema na acentuação.

3 respostas

Olá!

Deve haver uma paridade entre o valor que você colocou na tag meta e a codificação do arquivo salvo. Sem a tag meta, o Chrome (apenas o Chrome) detecta com a codificação do se arquivo. Porém, se você salvou seu arquivo em latim1 e colocou a tag meta com UTF-8 não há paridade, ou seja, são informações diferentes e você terá problema.

Seu editor deve salvar os arquivos como UTF-8. Se não me engano, alguns editores do Windows salvam como latim1, então se colocar `

deve funcionar. Se não funcionar, é porque foi salvo em outra codificação.

Realmente!!!

Eu aprendi como seta o enconding no Sublime:

Para mudar o encoding do sublime, vá em Preferences>Settings, pesquise por default_encoding, após isso coloque o parâmetro na área de configuração do usuário e indique o encoding desejado.

Outro item que pode ser útil no seu caso é tornar visível o encoding no sublime, para isso, também em Preferences>Settings, procure por show_encoding, coloque o parâmetro na área de configuração do usuário e mude o valor para true.

Abrindo configurações

inserir a descrição da imagem aqui

inserir a descrição da imagem aqui

inserir a descrição da imagem aqui

inserir a descrição da imagem aqui

Dessa forma podemos garantir que o padrão do editor seja UTF-8.

Quer mergulhar em tecnologia e aprendizagem?

Receba a newsletter que o nosso CEO escreve pessoalmente, com insights do mercado de trabalho, ciência e desenvolvimento de software