Ainda não tem acesso? Estude com a gente! Matricule-se
Ainda não tem acesso? Estude com a gente! Matricule-se

"Angular parte 1: Fundamentos" e Node 8x.

Olá, estou começando o curso "Angular parte 1: Fundamentos", e já me deparei com problemas de versão de Node e Angular.

Sei que logo na primeira aula vem a seguinte observação:

"É necessário que usemos exatamente a versão 8.X do Node.js, mesmo que haja versões mais recentes."

mas as máquinas aqui da empresa já estão com as últimas versões tanto de Node quanto de Angular.

É possível seguir o curso com as versões atualizadas de Node e Angular? Como? O que devo fazer?

Grato.

3 respostas

Fala ai Mauricio, tudo bem?

É possível seguir o curso com as versões atualizadas de Node e Angular? Como? O que devo fazer?

Sim, é possível utilizar as versões mais recentes tanto do Angular quanto do Node, porém, pode haver mudanças de código referente ao curso.

Caso queira prosseguir com as versões atualizadas, você pode instalar a versão mais nova do Node e do Angular CLI.

Espero ter ajudado.

Pelo o que eu vi, não consigo instalar o webapi do curso. Então eu teria então que criar o meu próprio webapi e adaptar o código do curso ao meu webapi. É isso?

Não, você pode utilizar a mesma API do curso, ela é separada do projeto front-end.

Você pode baixá-la, configurá-la e subir normalmente.

Pode ser que dê algum problema por conta da versão do Node.

Espero ter ajudado.